Skocz do zawartości



Wersja stabilna - Multi Theft Auto: San Andreas 1.5.3

MTASA 1.5.3

  • Nie możesz odpowiedzieć
Brak odpowiedzi do tego tematu

#1 Szybki

    Godfather

  • Zarząd
  • 1711 postów

Napisano 21 październik 2016 - 09:06

Posted Image


Wczoraj w godzinach popołudniowych na forum Multi Theft Auto pojawiła się informacja o opublikowanej nowej stabilnej wersji modu - Multi Theft Auto: San Andreas 1.5.3! Jedna część ekipy w głównej mierze podjęła się pracy czyszczeniu kodu i jego reorganizacji, co w głównej mierze powinno ułatwić pracę developerom w przyszłości, natomiast druga część pracowała nad poprawianiem błędów zgłaszanych przez społeczność. Dodatkowo zaktualizowano komponenty firm trzecich, które są wykorzystywane w silniku multiplayera, m.in. SQlite, zlib, libpng, libjpeg, CEF (Chromium Embedded Framework).

Natomiast developerzy informują że aktualizacja ta może być nieco kłopotliwa dla niektórych graczy, którzy w dalszym ciągu korzystają z Windowsa XP lub Windows Vista (lecz statystycznie ich jest coraz mniej). Ze względu na to że komponent CEF w najnowszej wersji nie jest kompatybilna z tymi wersjami systemów, dlatego też developerzy modu podjęli decyzję nad wypuszczeniem dwóch wersji, gdzie w przypadku wyżej wymienionych systemów wersja CEF jest lekko starsza. Ponadto tacy użytkownicy muszą być przygotowani, że w pewnym momencie developerzy mogą porzucić wsparcie dla Windowsa XP oraz Windows Vista, lecz jest to kolejny idealny argument by użytkownicy przesiedli się z dziurawych systemów na nowsze.

W poniższej liście zostały umieszczone niektóre z najbardziej interesujących zmian w tej wersji silniku multiplayera:
  • Dodano wsparcie dla wersji Niemieckiej Steam GTA:SA
  • Usprawniono streaming LOD i zwiększono limit
  • Poprawiono wiele błędów powodujące crashe
  • Czyszczenie kodu i usprawniono rejestrowanie błędów
  • MTA:SA będzie teraz próbowało użyć natywnej rozdzielczości przy pierwszym uruchomieniu
  • Usunięto błąd powodujący problemy z rodzielczością ekranu przy minimalizowaniu z pełnoekranowego trybu okienkowego
  • Dodano informacje o ścieżce zasobów klienta do zakładki Zaawansowane w oknie Opcje
  • Dodano ikonę dla aplikacji Windows Serwer i dodano podpis cyfrowy dla CEFLauncher
  • Nowe funkcje skryptowe: canBrowserNavigateBack(), canBrowserNavigateForward(), navigateBrowserBack(), navigateBrowserForward(), reloadBrowserPage(), createTrayNotification(), isTrayNotificationEnabled(), resizeBrowser(), fileGetPath(), setVehicleWindowOpen() i więcej...
  • Poprawki w dbQuery(), dbExec(), FileRead(), addDebugHook() i więcej...
  • Poprawiono setBrowserAudio() - nie wyciszanie poprawnie dźwięku na niektórych stronach np. YouTube
  • Poprawiono setCamaraTarget() - obliczenia
  • setVehiclePlateText() działa teraz na wszelkiego rodzaju pojazdów, w tym motocykli
  • Dodano wsparcie dla obiektów i broni dla pedów przy evencie uszkodzeń
  • Usunięto błąd nie ładujących się niestandardowych tekstur
  • Usunięto błąd powolnej aktualizacji pozycji do dołączonego elementu
  • Usprawniono kwestie bezpieczeństwa i wydajności dla CEF
  • Usunięto błąd okienek w CEF (np <select>) nie są wyświetlane poprawnie
  • Dodano możliwość blokowania logowania na administratorów, którzy wykonują to na nieznanym serialem
  • Duplikujące się linijki w dzienniku debugu będą od teraz pojawiać się tylko w jednej linijce
  • Usunięto błąd powodujący problem z łączeniem się na serwer, którzy są blokowani przez startujący skrypt
  • Poprawiono walidację plików zasobów klienta
  • Dodano logowanie funkcji redirectPlayer
  • Usprawnienia w zasobach (admin, missiontimer, race, runcode i webbrowser)
  • Dodano kopie zapasowe dla map w Map Editorze oraz domyślną wartością dla FPS limit został zmieniony z 36 na 50
  • Usunięto potrzebę posiadania paczki VS2008 redist
  • i wiele więcej!
Pełną listę zmian można znaleźć na Wiki oraz tutaj (od r7816 w górę). Listę zmian w pakiecie zasobów można znaleźć tutaj (począwszy od 18 lutego w górę).

Należy również pamiętać że UltraThing i starsze wersje modów serii ENB są blokowane przez MTA:SA 1.5.3 ze względu na niezgodność komponentów CEF. W przypadku ENB jest sprawa prosta, wystarczy ją zaaktualizować do najnowszej wersji, zaś w przypadku UltraThing nic nie można na ten moment zrobić.

Pobierz:
Windows - Multi Theft Auto 1.5.3
Windows - Multi Theft Auto 1.5.3 (Dla Windowsa XP i Vista)
Linux - Multi Theft Auto 1.5.3

//Aktualizacja:
Wyskakuje wam po odpaleniu MTA błąd "The program can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer."? Wystarczy wykonać poniższe kroki:

Krok 1 (instalacja paczuszki):
64 bit Windows 7: https://nightly.mtas...2999226-x64.msu
32 bit Windows 7: https://nightly.mtas...2999226-x86.msu
64 bit Windows 8: https://nightly.mtas...2999226-x64.msu
32 bit Windows 8: https://nightly.mtas...2999226-x86.msu
64 bit Windows 8.1: https://nightly.mtas...2999226-x64.msu
32 bit Windows 8.1: https://nightly.mtas...2999226-x86.msu


Krok 2:
Pobranie https://nightly.mtas...st_2015_x86.exe
Uruchomić vcredist_2015_x86.exe i zaznaczyć 'Uninstall'

Uruchomić ponownie vcredist_2015_x86.exe i zaznaczyć 'Install'

W przypadku dalszych problemów zainstalować wszystkie oczekujące aktualizacje windowsa.





Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych